1
1
mirror of https://github.com/LnL7/nix-darwin.git synced 2024-07-14 16:00:36 +03:00
nix-darwin/tests/fonts.nix
Emily 7d4f867210 fonts: remove fonts.fontDir.enable
As far as I can tell, this isn't required to get fonts to work on
NixOS, so we shouldn't require it on nix-darwin either, even if the
implementations are superficially similar.
2024-06-13 11:56:58 +01:00

21 lines
414 B
Nix

{ config, pkgs, ... }:
let
font = pkgs.runCommand "font-0.0.0" {} ''
mkdir -p $out
touch $out/Font.ttf
'';
in
{
fonts.packages = [ font ];
test = ''
echo "checking fonts in /Library/Fonts/Nix Fonts" >&2
test -e "${config.out}/Library/Fonts/Nix Fonts"/*/Font.ttf
echo "checking activation of fonts in /activate" >&2
grep '/Library/Fonts/Nix Fonts' ${config.out}/activate
'';
}