1
1
mirror of https://github.com/LnL7/nix-darwin.git synced 2024-07-14 16:00:36 +03:00
nix-darwin/tests/launchd-daemons.nix
2019-03-22 20:49:53 +01:00

18 lines
695 B
Nix

{ config, pkgs, ... }:
{
launchd.daemons.foo.command = "foo";
launchd.agents.bar.command = "bar";
launchd.user.agents.baz.command = "baz";
test = ''
echo "checking launchd load in /activate" >&2
grep "launchctl load .* '/Library/LaunchDaemons/org.nixos.foo.plist" ${config.out}/activate
grep "launchctl load .* '/Library/LaunchAgents/org.nixos.bar.plist" ${config.out}/activate
echo "checking launchd load in /activate-user" >&2
grep "launchctl load .* ~/Library/LaunchAgents/org.nixos.baz.plist" ${config.out}/activate-user
echo "checking LaunchAgents creation /activate-user" >&2
grep "mkdir -p ~/Library/LaunchAgents" ${config.out}/activate-user
'';
}