1
1
mirror of https://github.com/LnL7/nix-darwin.git synced 2024-07-14 16:00:36 +03:00
nix-darwin/tests/programs-ssh-empty-known-hosts.nix

12 lines
254 B
Nix

{ config, pkgs, ... }:
{
test = ''
echo >&2 "checking existance of /etc/ssh/ssh_known_hosts"
if test -e ${config.out}/etc/ssh/ssh_known_hosts; then
echo >&2 "/etc/ssh/ssh_known_hosts exists but it shouldn't!"
exit 1
fi
'';
}