1
1
mirror of https://github.com/LnL7/nix-darwin.git synced 2024-07-14 16:00:36 +03:00
nix-darwin/tests/services-dnsmasq.nix
Łukasz Niemier bd75d14b0f
fix: use separate config option to set port of DNSmasq
Older approach seems to not work on macOS 11 Big Sur for some reason.
2021-01-28 14:09:30 +01:00

27 lines
800 B
Nix

{ config, lib, pkgs, ... }:
with lib;
let
dnsmasq = pkgs.runCommand "dnsmasq-0.0.0" {} "mkdir $out";
in
{
services.dnsmasq.enable = true;
services.dnsmasq.package = dnsmasq;
services.dnsmasq.addresses = {
localhost = "127.0.0.1";
};
test = ''
echo >&2 "checking dnsmasq service in /Library/LaunchDaemons"
grep "org.nixos.dnsmasq" ${config.out}/Library/LaunchDaemons/org.nixos.dnsmasq.plist
grep "${dnsmasq}/bin/dnsmasq" ${config.out}/Library/LaunchDaemons/org.nixos.dnsmasq.plist
grep -F -- "--address=/localhost/127.0.0.1" ${config.out}/Library/LaunchDaemons/org.nixos.dnsmasq.plist
echo >&2 "checking resolver config"
grep -F "port 53" ${config.out}/etc/resolver/localhost
grep -F "nameserver 127.0.0.1" ${config.out}/etc/resolver/localhost
'';
}