1
1
mirror of https://github.com/LnL7/nix-darwin.git synced 2024-07-14 16:00:36 +03:00
nix-darwin/tests/services-privoxy.nix
2018-08-02 10:09:22 +10:00

24 lines
718 B
Nix

{ config, lib, pkgs, ... }:
with lib;
let
privoxy = pkgs.runCommand "privoxy-0.0.0" {} "mkdir $out";
in
{
services.privoxy.enable = true;
services.privoxy.package = privoxy;
services.privoxy.config = "forward / .";
test = ''
echo >&2 "checking privoxy service in ~/Library/LaunchAgents"
grep "org.nixos.privoxy" ${config.out}/user/Library/LaunchAgents/org.nixos.privoxy.plist
echo grep "${privoxy}/bin/privoxy" ${config.out}/user/Library/LaunchAgents/org.nixos.privoxy.plist
grep "${privoxy}/bin/privoxy" ${config.out}/user/Library/LaunchAgents/org.nixos.privoxy.plist
echo >&2 "checking config in /etc/privoxy-config"
grep "forward / ." ${config.out}/etc/privoxy-config
'';
}