1
1
mirror of https://github.com/LnL7/nix-darwin.git synced 2024-07-14 16:00:36 +03:00
nix-darwin/tests/services-spotifyd.nix
2021-03-11 04:20:00 +00:00

19 lines
472 B
Nix

{ config, lib, pkgs, ... }:
with lib;
let
spotifyd = pkgs.runCommand "spotifyd-0.0.0" {} "mkdir $out";
in
{
services.spotifyd.enable = true;
services.spotifyd.package = spotifyd;
test = ''
echo >&2 "checking spotifyd service in ~/Library/LaunchAgents"
grep "org.nixos.spotifyd" ${config.out}/user/Library/LaunchAgents/org.nixos.spotifyd.plist
grep "${spotifyd}/bin/spotifyd" ${config.out}/user/Library/LaunchAgents/org.nixos.spotifyd.plist
'';
}