1
1
mirror of https://github.com/LnL7/nix-darwin.git synced 2024-07-14 16:00:36 +03:00
nix-darwin/tests/system-environment.nix
2018-10-29 09:12:20 +09:00

19 lines
590 B
Nix

{ config, pkgs, ... }:
{
programs.bash.enable = true;
programs.fish.enable = true;
programs.zsh.enable = true;
test = ''
echo checking setEnvironment in /etc/bashrc >&2
fgrep '. ${config.system.build.setEnvironment}' ${config.out}/etc/bashrc
echo checking setEnvironment in /etc/fish/nixos-env-preinit.fish >&2
grep 'fenv source ${config.system.build.setEnvironment}' ${config.out}/etc/fish/nixos-env-preinit.fish
echo checking setEnvironment in /etc/zshenv >&2
fgrep '. ${config.system.build.setEnvironment}' ${config.out}/etc/zshenv
'';
}