1
1
mirror of https://github.com/NixOS/mobile-nixos.git synced 2024-09-11 03:55:23 +03:00
mobile-nixos/boot/error/default.nix
2022-09-26 23:42:22 -04:00

22 lines
500 B
Nix

{ lib, runCommand, mobile-nixos }:
let
assets = runCommand "boot-error-assets" {} ''
mkdir -p $out
cp ${../../artwork/sad.svg} $out/sad.svg
'';
in
mobile-nixos.mkLVGUIApp {
name = "boot-error.mrb";
executablePath = "libexec/boot-error.mrb";
src = lib.cleanSource ./.;
rubyFiles = [
"${../lib}/hal/reboot_modes.rb"
"${../lib}/init/configuration.rb"
"$(find ./lib -type f -name '*.rb' | sort)"
"main.rb"
];
inherit assets;
assetsPath = "boot-error/assets";
}