1
1
mirror of https://github.com/NixOS/mobile-nixos.git synced 2024-10-05 16:57:13 +03:00
mobile-nixos/shell.nix
chayleaf d63c2a8d64
further remove deprecated URL literals and unused vars
Turns out nvim has a tab limit, so I didn't get all of them last time.

- Remove the last usages of URL literals
- All unused variables and arguments (the only exceptions are module
  args and lib) are removed
- Clean up a couple more unused recs
2023-12-15 17:13:07 +07:00

28 lines
937 B
Nix

{ pkgs ? import ./pkgs.nix { } }:
let pkgs' = pkgs; in # Break the cycle
let
pkgs = pkgs'.appendOverlays [
(import ./overlay/overlay.nix)
];
in
# A basic shell with some tools available for porting devices.
pkgs.mkShell {
name = "nixos-mobile";
buildInputs = with pkgs; [
# Custom tools
mobile-nixos.autoport # Helps users kickstart their ports
# Third party tools
android-tools # For flashing android devices with fastboot
dtc # For playing around with device tree files
dtbTool # Combines multiple device tree blobs into one image
file # Shows the type of files
lz4 # Decompress image files
mkbootimg # Pack and unpack boot images
python3Packages.binwalk # Search a binary image for embedded files
ubootTools # A couple useful utilities
];
}