1
1
mirror of https://github.com/NixOS/mobile-nixos.git synced 2024-09-11 12:05:26 +03:00
mobile-nixos/support/kernel-config/networking.nix
chayleaf d63c2a8d64
further remove deprecated URL literals and unused vars
Turns out nvim has a tab limit, so I didn't get all of them last time.

- Remove the last usages of URL literals
- All unused variables and arguments (the only exceptions are module
  args and lib) are removed
- Clean up a couple more unused recs
2023-12-15 17:13:07 +07:00

29 lines
565 B
Nix

{ config, lib, pkgs, ... }:
let
inherit (lib)
mkDefault
;
mkDefaultIze =
attrs:
builtins.mapAttrs (_: value: mkDefault value) attrs
;
in
{
mobile.kernel.structuredConfig = [
# Removing stuff unneeded by default
(helpers: with helpers; mkDefaultIze {
IP_SET = no;
IP_VS = no;
NET_DSA = no;
})
(helpers: with helpers; mkDefaultIze {
NET_SCHED = yes;
# The name implies routing... but virtual stuff would apply here.
# E.g. android roots, etc...
IP_ADVANCED_ROUTER = yes;
})
];
}