haskell-urbit-api/shell.nix
2020-11-29 09:59:25 -05:00

18 lines
344 B
Nix

{ nixpkgs ? import ./nixpkgs.nix
, compiler ? "ghc884"
}:
nixpkgs.mkShell {
name = "urbit-api-shell";
buildInputs = [
nixpkgs.ormolu.bin
(nixpkgs.pkgs.haskell.packages.${compiler}.ghcWithPackages (hp: with hp; [
aeson base bytestring conduit conduit-extra http-client modern-uri
req req-conduit text uuid
]))
];
}