rel8/default.nix
Ollie Charles 9ccae597b9 Fix CI
2021-03-02 15:07:44 +00:00

30 lines
539 B
Nix

let
haskellNix = import (import ./nix/sources.nix)."haskell.nix" {};
nixpkgsSrc = haskellNix.sources.nixpkgs-2009;
nixpkgsArgs = haskellNix.nixpkgsArgs;
compiler-nix-name = "ghc8103";
pkgs = import nixpkgsSrc nixpkgsArgs;
in
pkgs.haskell-nix.project {
inherit compiler-nix-name;
src = pkgs.haskell-nix.haskellLib.cleanGit {
name = "rel8";
src = ./.;
};
modules = [
{ packages.rel8 = {
preCheck = ''
export PATH="${pkgs.postgresql}/bin:${"$PATH"}"
'';
};
}
];
}