mirror of
https://github.com/dhall-lang/dhall-kubernetes.git
synced 2024-11-03 21:05:47 +03:00
8d295ecedc
This makes our build reproducible and consistent * Disables dhall tests. They don't build in sandbox mode because they require network access * Moves all scripts to ./scripts folder for consistency * Moves all nix files to ./nix folder for consistency, except for release.nix which Hydra needs * Changes convert.py to take the K8s swagger spec as an argument * Get k8s swagger spec from nixpkgs * Get dhall prelude from nixpkgs * added an ./scripts/update-nixpkgs.sh script to easily update to a new version of nixpkgs
10 lines
219 B
Nix
10 lines
219 B
Nix
{stdenv, kubernetes}:
|
|
stdenv.mkDerivation {
|
|
name = "kubernetes-openapi-spec";
|
|
src = kubernetes.src;
|
|
phases = [ "unpackPhase" "installPhase" ];
|
|
installPhase = ''
|
|
cp api/openapi-spec/swagger.json $out
|
|
'';
|
|
}
|