dhall-kubernetes/release.nix
Arian van Putten 8d295ecedc
Nixify the build (#55)
This makes our build reproducible and consistent

* Disables dhall tests. They don't build in sandbox mode because they require network access
* Moves all scripts to ./scripts folder for consistency
* Moves all nix files to ./nix folder for consistency, except for release.nix which Hydra needs
* Changes convert.py to take the K8s swagger spec as an argument
* Get k8s swagger spec from nixpkgs
* Get dhall prelude from nixpkgs
* added an ./scripts/update-nixpkgs.sh script to easily update to a new version of nixpkgs
2019-03-30 11:05:29 +01:00

18 lines
603 B
Nix

{ pkgs ? import ./nix/nixpkgs.nix
, src ? { rev = ""; }
, ...
}:
rec {
inherit (pkgs) dhall-kubernetes;
# Derivation that trivially depends on the input source code revision.
# As this is included in the "dhall-lang" aggregate, it forces every
# commit to have a corresponding GitHub status check, even if the
# commit doesn't make any changes (which can happen when merging
# master in).
rev = pkgs.runCommand "rev" {} ''echo "${src.rev}" > $out'';
aggregate = pkgs.releaseTools.aggregate {
name = "dhall-kubernetes-agggregate";
constituents = [ dhall-kubernetes rev ];
};
}