mirror of
https://github.com/dhall-lang/dhall-kubernetes.git
synced 2024-11-03 21:05:47 +03:00
7af2ab5345
* Also update to the latest version of `dhall` * Also fix `./scripts/generate.sh` to generate the `schemas*` files
23 lines
769 B
Nix
23 lines
769 B
Nix
{ mkDerivation, aeson, base, bytestring, stdenv, string-qq, tasty
|
|
, tasty-discover, tasty-hunit, text, unordered-containers, vector
|
|
, yaml
|
|
}:
|
|
mkDerivation {
|
|
pname = "aeson-yaml";
|
|
version = "1.0.4.0";
|
|
sha256 = "7a6ddaad23f50dc7b419707e49904ad3b5ea9fcd29d2cae0e4adaf300fbb8264";
|
|
isLibrary = true;
|
|
isExecutable = true;
|
|
libraryHaskellDepends = [
|
|
aeson base bytestring text unordered-containers vector
|
|
];
|
|
executableHaskellDepends = [ aeson base bytestring ];
|
|
testHaskellDepends = [
|
|
aeson base bytestring string-qq tasty tasty-discover tasty-hunit
|
|
unordered-containers yaml
|
|
];
|
|
homepage = "https://github.com/clovyr/aeson-yaml";
|
|
description = "Output any Aeson value as YAML (pure Haskell library)";
|
|
license = stdenv.lib.licenses.bsd3;
|
|
}
|