dhall-kubernetes/release.nix
Gabriel Gonzalez f991aecf91 Switch to dhall-openapi project
The `dhall-openapi` subproject from the `dhall-haskell` repository
supersedes `dhall-kubernetes-generator`, so this change switches over
to using that project.
2020-08-10 08:37:57 -07:00

24 lines
761 B
Nix

{ pkgs ? import ./nix/nixpkgs.nix
, src ? { rev = ""; }
, ...
}:
let
products = {
# Derivation that trivially depends on the input source code revision.
# As this is included in the "dhall-lang" aggregate, it forces every
# commit to have a corresponding GitHub status check, even if the
# commit doesn't make any changes (which can happen when merging
# master in).
rev = pkgs.runCommand "rev" {} ''echo "${src.rev}" > $out'';
} // builtins.removeAttrs pkgs.dhall-kubernetes
[ "override" "overrideDerivation" ];
dhall-kubernetes = pkgs.releaseTools.aggregate {
name = "dhall-kubernetes-aggregate";
constituents = pkgs.lib.mapAttrsToList (_: v: v) products;
};
in
products // { inherit dhall-kubernetes; }