dhall-kubernetes/shell.nix
Thomas Scholtes 4a7f02cd0d Extract and check examples (#27)
* We move all the example code from the readme to the `examples` folder.
* We provide a `scripts/build-readme.sh` script that inlines referenced
  examples in `README.md.in` and outputs `README.md`. The script also
  verifies that the output readme is the same as in version control.
* We provide a `scripts/build-examples.py` script that builds the Yaml
  output for all examples. The script also verifies that the generated
  Yaml files are the same as in version control.
2018-08-03 16:24:32 +02:00

16 lines
290 B
Nix

let
pkgs = import ./nixpkgs.nix;
in
pkgs.stdenv.mkDerivation {
name = "dhall-kubernetes-shell";
buildInputs = [
pkgs.git
pkgs.dhall
pkgs.dhall-json
pkgs.dhall-text
pkgs.python3
pkgs.python3Packages.requests
pkgs.glibcLocales
];
}