1
1
mirror of https://github.com/divnix/digga.git synced 2024-07-07 03:46:20 +03:00
digga/default.nix
2022-11-12 06:02:28 -05:00

23 lines
546 B
Nix

let
inherit
(import
(
let
lock = builtins.fromJSON (builtins.readFile ./flake.lock);
in
fetchTarball {
url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
sha256 = lock.nodes.flake-compat.locked.narHash;
}
)
{src = ./.;})
defaultNix
;
in
# Pass this flake as inputs.digga
defaultNix
// {
inputs = defaultNix.inputs // {digga = defaultNix;};
shell = import ./devShell.nix {};
}