1
1
mirror of https://github.com/divnix/digga.git synced 2024-08-15 18:10:24 +03:00
digga/examples/hmOnly/flake.nix
Yannis Koutras bca4b89f49 Update home-manager to 22.11
This commit updates the home-manager flake input to the 22.11 release
and creates additional support for the new homeManagerConfiguration
setup that is introduced there: Some arguments that were previously
in use, now need to be used inside the new modules argument (check
[here][hm-22.11-highlights] for more details).

Finally, the examples of using home-manager now declare explicitly the
stateVersion, since the 22.11 release makes this mandatory.

[hm-22.11-highlights]: https://nix-community.github.io/home-manager/release-notes.html#sec-release-22.11-highlights
2023-01-06 13:47:48 -05:00

29 lines
606 B
Nix

{
description = "A DevOS example. And also a digga test bed.";
inputs = {
nixos.url = "github:nixos/nixpkgs/nixos-22.11";
digga.url = "github:divnix/digga";
digga.inputs.nixpkgs.follows = "nixos";
digga.inputs.home-manager.follows = "home";
home.url = "github:nix-community/home-manager/release-22.11";
home.inputs.nixpkgs.follows = "nixos";
};
outputs = inputs @ {
self,
nixos,
digga,
home,
}:
digga.lib.mkFlake {
inherit self inputs;
channels.nixos = {};
nixos.hostDefaults.channelName = "nixos";
home = ./home;
};
}