1
1
mirror of https://github.com/haskell/lsp.git synced 2024-10-03 18:37:27 +03:00
lsp/shell.nix
Michael Peyton Jones 483e641eaf
Simplify nix setup (#531)
* Simplify nix setup

This doesn't try to build the dependencies, just provides GHC/cabal/HLS.

* Add cabal-fmt and fourmolu

* Updated fourmolu

* Use the default GHC
2023-11-26 17:47:53 +00:00

16 lines
306 B
Nix

{ nixpkgs ? import ./nix { } }:
with nixpkgs;
let
hsPkgs = haskellPackages;
ghc = haskellPackages.ghc;
in mkShell {
nativeBuildInputs = [
hsPkgs.ghc
hsPkgs.haskell-language-server
haskellPackages.cabal-fmt
haskellPackages.fourmolu
cabal-install
zlib
pkg-config ];
}