mirror of
https://github.com/hasura/graphql-engine.git
synced 2024-12-13 19:33:55 +03:00
4b1cf9bee7
GHC 9.6.4 has finally been merged into nixpkgs! (This took far longer than anticipated.) We can now upgrade to get our hands on it. I had to remove the console dev tools from the Nix shell because node.js 16 is EOL and not available in the latest nixpkgs. PR-URL: https://github.com/hasura/graphql-engine-mono/pull/10729 GitOrigin-RevId: f7236c9e284a467bfac4897afb9d452dd103786d
15 lines
390 B
Nix
15 lines
390 B
Nix
{ pkgs }:
|
|
let
|
|
versions = pkgs.lib.trivial.importJSON ../server/VERSIONS.json;
|
|
in
|
|
{
|
|
ensureVersion = package:
|
|
let expected = versions.${package.pname};
|
|
in
|
|
if expected == package.version
|
|
then package
|
|
else throw "Invalid version for package ${package.pname}: expected ${expected}, got ${package.version}";
|
|
|
|
ghcVersion = pkgs.lib.strings.fileContents ../.ghcversion;
|
|
}
|