haskell.nix/test/fully-static/cross.nix
Hamish Mackenzie d5d304d5b5
Flakify all inputs (#1180)
* Include dependencies of haskell.nix that were tracked in `nix/sources.json`
  as flake inputs (`flake.lock` replaces `nix/sources.json`).
* Use `flake-compat` to continue to provide a compatible interface for non
  flake projects.

Co-authored-by: Alexander Bantyev <balsoft@balsoft.ru>
Co-authored-by: Shea Levy <shea@shealevy.com>
2021-08-06 15:54:39 +12:00

16 lines
327 B
Nix

{ pkgs ? import nixpkgs { }
, nixpkgs ? (import ../.. { }).sources.nixpkgs
}:
let
pkgs' = pkgs.pkgsCross.musl64;
haskellMusl64 = pkgs.callPackage ../.. { pkgs = pkgs'; };
test = haskellMusl64.callPackage ./default.nix {
inherit (pkgs') buildPackages;
};
in {
inherit (test) pandoc-gmp pandoc-integer-simple;
}