haskell.nix/test/util.nix
Rodney Lorrimar 33e8d115f7 tests: Add more tests for "all" component merging
- Make the cabal-simple executable depend on the library component --
  a better exercise for the merged all component build.

- Test building cabal-simple with "cabal new-build" in nix-shell.

- Check the contents of components.all.depends for the with-packages test.
2019-02-07 09:39:12 +08:00

9 lines
233 B
Nix

{ cabal-install }:
{
# Add cabal as a buildInput for a haskell derivation. Useful for nix-shell.
addCabalInstall = drv: drv.overrideAttrs (oldAttrs: {
buildInputs = (oldAttrs.buildInputs or []) ++ [ cabal-install ];
});
}