servant-reflex/shell.nix
2018-03-17 16:13:15 -04:00

10 lines
247 B
Nix

{ nixpkgs ? import <nixpkgs> {}
, compiler ? "ghc"
} :
let
inherit (nixpkgs) pkgs;
reflex-platform = import ./nix/reflex-platform.nix;
drv = import ./. { inherit reflex-platform compiler; };
in
if pkgs.lib.inNixShell then drv.env else drv