mirror of
https://github.com/ilyakooo0/urbit.git
synced 2024-12-15 01:52:42 +03:00
ce3cbf0857
This also removes nixcrpkgs and OSX cross compilation in favour of compiling on the target. x86_64/musl targets are still supported on Linux. All sources are now managed via niv (see nix/sources.json) and Haskell package sets are provided/organised via IOHK's haskell.nix. Some effort has been made to expose similar top-level attributes for development, but in some cases there have been changes. Please see the comments in the top-level default.nix and ci.nix files for usage.
12 lines
303 B
Diff
12 lines
303 B
Diff
--- a/src/fault-linux-arm.h
|
|
+++ b/src/fault-linux-arm.h
|
|
@@ -17,6 +17,8 @@
|
|
|
|
#include "fault-posix-ucontext.h"
|
|
|
|
+#define HAVE_STACKVMA 0
|
|
+
|
|
#if defined(__aarch64__) || defined(__ARM_64BIT_STATE) || defined(__ARM_PCS_AAPCS64) /* 64-bit */
|
|
|
|
/* See glibc/sysdeps/unix/sysv/linux/aarch64/sys/ucontext.h.
|