mirror of
https://github.com/infinisil/all-hies.git
synced 2024-11-22 04:43:27 +03:00
b8fb659620
* Remove update command Will be replaced with haskell.nix * Project revamp using haskell.nix - Only unstable HIE - Only GHC 8.6.5 and 8.8.3 (or more in the future), but on Linux for both glibc 2.27 (NixOS 19.09) and glibc 2.30 (NixOS 20.03/unstable) - Using haskell.nix for the builds. This makes evaluation slower, but makes things simpler overall. - No global installation intended anymore, instead you add HIE to your projects shell.nix file (to be documented in future commits) Co-authored-by: galagora <45048741+galagora@users.noreply.github.com> * Remove old files not needed anymore with the revamp * Add new haskell.nix-generated files * Add haskell.nix template * Add nixpkgs infra template * Build, push and test using GitHub Actions This builds and pushes all necessary configurations using GitHub Actions automatically. Also tests the templates * Update Readme for revamp * Add template documentation * Add warning for unsupported versions * Add haskell.nix + stack template * Minor Readme changes * Remove check-cache script * Don't CI on pushes to haskell.nix * Use same haskell.nix version for stack/cabal + cleanups Co-authored-by: galagora <45048741+galagora@users.noreply.github.com>
19 lines
537 B
Nix
19 lines
537 B
Nix
{}:
|
|
let
|
|
legacyError = throw ''
|
|
all-hies has undergone major changes and now needs to be used on a per-project basis.
|
|
See https://github.com/Infinisil/all-hies/blob/master/Readme.md for more info.
|
|
The last version that doesn't have these changes is 4b6aab017cdf96a90641dc287437685675d598da.
|
|
'';
|
|
in {
|
|
overlay = import ./overlay.nix;
|
|
|
|
combined = legacyError;
|
|
versions = legacyError;
|
|
selection = legacyError;
|
|
latest = legacyError;
|
|
unstable = legacyError;
|
|
bios = legacyError;
|
|
unstableFallback = legacyError;
|
|
}
|