crane/checks/smoke.nix
Ivan Petkov 05c8945db7
tests: switch back to runCommand from runCommandLocal
* Seems like cachix is still pushing the results up to the cache, we
  might as well get use of downloading the (empty) results rather than
  having to pull down the intermediary binaries and running them each
  time
2022-02-17 18:15:09 -08:00

14 lines
214 B
Nix

{ runCommand
}:
bins: drv:
let
testList = map (b: "${drv}/bin/${b}") bins;
tests = builtins.concatStringsSep "\n" testList;
in
runCommand "smoke-${drv.name}" { } ''
# does it run?
${tests}
touch $out
''