mirror of
https://github.com/ipetkov/crane.git
synced 2024-11-26 09:08:57 +03:00
6f7504ad93
Callers should use `mkLib` with an instantiation of `pkgs` instead of using `crane.lib.${system}` directly
16 lines
504 B
Nix
16 lines
504 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
|
|
crane.url = "github:ipetkov/crane";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = { nixpkgs, flake-utils, crane, ... }: flake-utils.lib.eachDefaultSystem
|
|
(system: {
|
|
packages.cargo-git = (crane.mkLib nixpkgs.legacyPackages.${system}).downloadCargoPackageFromGit {
|
|
git = "https://github.com/rust-lang/cargo";
|
|
rev = "17f8088d6eafd82349630a8de8cc6efe03abf5fb";
|
|
};
|
|
});
|
|
}
|