mirror of
https://github.com/ipetkov/crane.git
synced 2024-11-25 21:42:20 +03:00
6f7504ad93
Callers should use `mkLib` with an instantiation of `pkgs` instead of using `crane.lib.${system}` directly
65 lines
1.6 KiB
Nix
65 lines
1.6 KiB
Nix
{
|
|
description = "Cross compiling a rust program for windows";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
|
|
|
|
crane.url = "github:ipetkov/crane";
|
|
|
|
fenix = {
|
|
url = "github:nix-community/fenix";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = { nixpkgs, crane, fenix, flake-utils, ... }:
|
|
flake-utils.lib.eachDefaultSystem (system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
|
|
toolchain = with fenix.packages.${system};
|
|
combine [
|
|
minimal.rustc
|
|
minimal.cargo
|
|
targets.x86_64-pc-windows-gnu.latest.rust-std
|
|
];
|
|
|
|
craneLib = (crane.mkLib pkgs).overrideToolchain toolchain;
|
|
|
|
my-crate = craneLib.buildPackage {
|
|
src = craneLib.cleanCargoSource ./.;
|
|
|
|
strictDeps = true;
|
|
doCheck = false;
|
|
|
|
CARGO_BUILD_TARGET = "x86_64-pc-windows-gnu";
|
|
|
|
# fixes issues related to libring
|
|
TARGET_CC = "${pkgs.pkgsCross.mingwW64.stdenv.cc}/bin/${pkgs.pkgsCross.mingwW64.stdenv.cc.targetPrefix}cc";
|
|
|
|
#fixes issues related to openssl
|
|
OPENSSL_DIR = "${pkgs.openssl.dev}";
|
|
OPENSSL_LIB_DIR = "${pkgs.openssl.out}/lib";
|
|
OPENSSL_INCLUDE_DIR = "${pkgs.openssl.dev}/include/";
|
|
|
|
depsBuildBuild = with pkgs; [
|
|
pkgsCross.mingwW64.stdenv.cc
|
|
pkgsCross.mingwW64.windows.pthreads
|
|
];
|
|
};
|
|
in
|
|
{
|
|
packages = {
|
|
inherit my-crate;
|
|
default = my-crate;
|
|
};
|
|
|
|
checks = {
|
|
inherit my-crate;
|
|
};
|
|
}
|
|
);
|
|
}
|