patat/flake.nix
Jasper Van der Jeugt b7c3b6d297 Add flake.nix
2024-09-28 14:46:13 +02:00

31 lines
739 B
Nix

{
description = "patat";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = inputs :
inputs.flake-utils.lib.eachDefaultSystem (system:
let pkgs = inputs.nixpkgs.legacyPackages.${system};
haskell = pkgs.haskell.packages.ghc98;
in
{
packages = {
default = haskell.callCabal2nix "patat" ./. {};
};
devShells = {
default = pkgs.mkShell {
packages = [
pkgs.cabal-install
pkgs.entr
haskell.goldplate
haskell.stylish-haskell
(haskell.ghc.withPackages (p: inputs.self.packages.${system}.default.buildInputs))
];
};
};
});
}