mirror of
https://github.com/jaspervdj/patat.git
synced 2024-11-22 06:23:46 +03:00
31 lines
739 B
Nix
31 lines
739 B
Nix
{
|
|
description = "patat";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = inputs :
|
|
inputs.flake-utils.lib.eachDefaultSystem (system:
|
|
let pkgs = inputs.nixpkgs.legacyPackages.${system};
|
|
haskell = pkgs.haskell.packages.ghc98;
|
|
in
|
|
{
|
|
packages = {
|
|
default = haskell.callCabal2nix "patat" ./. {};
|
|
};
|
|
devShells = {
|
|
default = pkgs.mkShell {
|
|
packages = [
|
|
pkgs.cabal-install
|
|
pkgs.entr
|
|
haskell.goldplate
|
|
haskell.stylish-haskell
|
|
(haskell.ghc.withPackages (p: inputs.self.packages.${system}.default.buildInputs))
|
|
];
|
|
};
|
|
};
|
|
});
|
|
}
|