spago2nix/ci.nix
justinwoo 3339d19826 update easy-purescirpt-nix dependency
mostly need to stop assuming i can actually build against latest
purescript, because nothing is stable
2021-05-08 13:12:35 +00:00

26 lines
471 B
Nix

{ pkgs ? import <nixpkgs> { } }:
let
easy-ps = import
(
pkgs.fetchFromGitHub {
owner = "justinwoo";
repo = "easy-purescript-nix";
rev = "e00a54ca6bd0290e8301eff140d109c1f300e40d";
sha256 = "1yrnnpxkzs59ik5dj9v67ysn4viff775v24kizpl0ylf24c74928";
}
) {
inherit pkgs;
};
spago2nix = import ./default.nix {
inherit pkgs;
};
in
pkgs.mkShell {
buildInputs = [
easy-ps.purs-0_13_8
spago2nix
];
}