nix-rehash/nix-services/environment.nix
2014-09-23 14:32:06 +02:00

27 lines
585 B
Nix

{ config, pkgs, ... }:
with pkgs.lib;
{
options = {
environment.systemPackages = mkOption {
default = [];
description = "Packages to be put in the system profile.";
};
environment.umask = mkOption {
default = "002";
type = with types; string;
};
# HACK HACK
system.activationScripts.etc = mkOption {}; # Ignore
system.build.etc = mkOption {}; # Ignore
environment.etc = mkOption {}; # Ignore
environment.sessionVariables = mkOption {}; # Ignore
};
config = {
environment.systemPackages = with pkgs; [ ];
};
}