flakelight/builtinModules/functor.nix
Archit Gupta 543e3aaa4d Replace nixpkgs nullOr type with custom type
`nullOr`'s merge function requires definitions to all be null or all be
non-null. It was being used where the intent was that null be used as a
value representing unset, and as such the merge should return null if
all definitions are null and ignore nulls otherwise. This adds a type
with that merge semantics.
2024-02-07 01:49:29 -08:00

21 lines
510 B
Nix

# flakelight -- Framework for simplifying flake setup
# Copyright (C) 2023 Archit Gupta <archit@accelbread.com>
# SPDX-License-Identifier: MIT
{ config, lib, flakelight, ... }:
let
inherit (lib) mkOption mkIf;
inherit (lib.types) functionTo raw uniq;
inherit (flakelight.types) nullable;
in
{
options.functor = mkOption {
type = nullable (uniq (functionTo (functionTo raw)));
default = null;
};
config.outputs = mkIf (config.functor != null) (_: {
__functor = config.functor;
});
}