flakelight/builtinModules/homeModules.nix
Archit Gupta 543e3aaa4d Replace nixpkgs nullOr type with custom type
`nullOr`'s merge function requires definitions to all be null or all be
non-null. It was being used where the intent was that null be used as a
value representing unset, and as such the merge should return null if
all definitions are null and ignore nulls otherwise. This adds a type
with that merge semantics.
2024-02-07 01:49:29 -08:00

34 lines
775 B
Nix

# flakelight -- Framework for simplifying flake setup
# Copyright (C) 2023 Archit Gupta <archit@accelbread.com>
# SPDX-License-Identifier: MIT
{ config, lib, flakelight, moduleArgs, ... }:
let
inherit (lib) mkOption mkIf mkMerge;
inherit (lib.types) lazyAttrsOf;
inherit (flakelight.types) module nullable optCallWith;
in
{
options = {
homeModule = mkOption {
type = nullable module;
default = null;
};
homeModules = mkOption {
type = optCallWith moduleArgs (lazyAttrsOf module);
default = { };
};
};
config = mkMerge [
(mkIf (config.homeModule != null) {
homeModules.default = config.homeModule;
})
(mkIf (config.homeModules != { }) {
outputs = { inherit (config) homeModules; };
})
];
}