mirror of
https://github.com/nix-community/flakelight.git
synced 2024-11-20 19:28:55 +03:00
543e3aaa4d
`nullOr`'s merge function requires definitions to all be null or all be non-null. It was being used where the intent was that null be used as a value representing unset, and as such the merge should return null if all definitions are null and ignore nulls otherwise. This adds a type with that merge semantics.
21 lines
531 B
Nix
21 lines
531 B
Nix
# flakelight -- Framework for simplifying flake setup
|
|
# Copyright (C) 2023 Archit Gupta <archit@accelbread.com>
|
|
# SPDX-License-Identifier: MIT
|
|
|
|
{ config, lib, flakelight, genSystems, ... }:
|
|
let
|
|
inherit (lib) mkIf mkOption;
|
|
inherit (lib.types) functionTo pkgs;
|
|
inherit (flakelight.types) nullable;
|
|
in
|
|
{
|
|
options.legacyPackages = mkOption {
|
|
type = nullable (functionTo pkgs);
|
|
default = null;
|
|
};
|
|
|
|
config.outputs = mkIf (config.legacyPackages != null) {
|
|
legacyPackages = genSystems config.legacyPackages;
|
|
};
|
|
}
|