nixos-anywhere/flake.nix
Jörg Thalheim 87fd12fb84 flake.lock: Update
Flake lock file updates:

• Updated input 'disko':
    'github:nix-community/disko/66add2cd9edab96f5e87477229772bf2b3ca513a' (2022-12-08)
  → 'github:nix-community/disko/e1eba38e8ea3ee6ca8ffef57668d4a37fff19ca4' (2023-01-19)
• Updated input 'nixos-images':
    'github:nix-community/nixos-images/b14097667f2a9889083d6401ba468b046b2b52f1' (2022-12-23)
  → 'github:nix-community/nixos-images/acbbb3494fdf4d7f8f8e8832beeab9c448563e9b' (2023-01-19)
• Updated input 'nixos-images/nixos-2211':
    'github:NixOS/nixpkgs/eabc38219184cc3e04a974fe31857d8e0eac098d' (2022-08-02)
  → 'github:NixOS/nixpkgs/f664029d68acdffe8d86e98a295b2d8303369353' (2023-01-18)
• Updated input 'nixos-images/nixos-unstable':
    'github:NixOS/nixpkgs/3c6d63d22ca8b57adc4120f7c1ea5262925c8c2d' (2022-12-20)
  → 'github:NixOS/nixpkgs/8fc3a1dcc98d3603221d4afd239e666eeedb6141' (2023-01-17)
• Updated input 'nixpkgs':
    'github:nixos/nixpkgs/6bc6f77cb171a74001033d94f17f49043a9f1804' (2022-12-09)
  → 'github:nixos/nixpkgs/cfb43ad7b941d9c3606fb35d91228da7ebddbfc5' (2023-01-20)
• Updated input 'treefmt-nix':
    'github:numtide/treefmt-nix/6717065d6a432bc3f5b827007ad959e6032d5856' (2023-01-05)
  → 'github:numtide/treefmt-nix/c117283f7482b99a89de0d6ae4b77318ad283294' (2023-01-21)
2023-01-22 13:13:20 +01:00

37 lines
1.2 KiB
Nix

{
description = "A universal nixos installer, just needs ssh access to the target system";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable-small";
flake-parts = { url = "github:hercules-ci/flake-parts"; inputs.nixpkgs-lib.follows = "nixpkgs"; };
disko = { url = "github:nix-community/disko/master"; inputs.nixpkgs.follows = "nixpkgs"; };
# used for testing
nixos-images.url = "github:nix-community/nixos-images";
# used for development
treefmt-nix.url = "github:numtide/treefmt-nix";
};
outputs = inputs:
inputs.flake-parts.lib.mkFlake { inherit inputs; } {
systems = [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
imports = [
./src/flake-module.nix
./tests/flake-module.nix
./docs/flake-module.nix
inputs.treefmt-nix.flakeModule
];
perSystem = { config, ... }: {
treefmt = {
projectRootFile = "flake.nix";
programs.nixpkgs-fmt.enable = true;
programs.shellcheck.enable = true;
programs.shfmt.enable = true;
settings.formatter.shellcheck.options = [ "-s" "bash" ];
};
formatter = config.treefmt.build.wrapper;
};
};
}