nixos-generators/default.nix
zimbatm 0cce7924f1 Cleanup (#17)
* rename eval-format.nix to nixos-generate.nix

Make it clear that it's meant to be used by the nixos-generate script

* rename config.nix to configuration.nix

Bring the name closer to /etc/nixos/configuration.nix

* fix the NIXOS_CONFIG

this is the env name that nixos-rebuild uses

* use -I to load the configuration and format

This has a nice side-effect of allowing URLs as configuration

* add Travis CI

* cleanSource

* gitignore nix result files

* use modulesPath everywhere

this makes sure that the passed pkgs in nixos-generate.nix is the same
one we use to load these other modules

* use toString to avoid evaluation error
2019-01-31 23:06:29 +01:00

14 lines
341 B
Nix

{ pkgs ? import <nixpkgs> {} }:
with pkgs;
stdenv.mkDerivation {
name = "nixos-generators";
src = lib.cleanSource ./.;
nativeBuildInputs = [ makeWrapper ];
installFlags = [ "PREFIX=$(out)" ];
postFixup = ''
wrapProgram $out/bin/nixos-generate \
--prefix PATH : ${lib.makeBinPath [ jq coreutils findutils nix ] }
'';
}