nixos-generators/formats/gce.nix
zimbatm 93e10d0aea central command (#8)
* WIP: eval target

* rename nixos-build to nixos-generate

* rename target to format

* allow to pass arbitrary format paths

* add --help option

* add --list option

* port the rest of the formats

* add short options

* be more precise with the file selection

* use new trick I learned

* support the --run option

for the no-gui version:

    ./nixos-generate --run -f vm-no-gui

* document

* fixup! port the rest of the formats

* fix kexec-bundle
2019-01-17 15:18:00 +01:00

9 lines
153 B
Nix

{ modulesPath, ... }:
{
imports = [
"${toString modulesPath}/virtualisation/google-compute-image.nix"
];
formatAttr = "googleComputeImage";
}