mirror of
https://github.com/nix-community/nixos-generators.git
synced 2024-11-22 18:24:59 +03:00
93e10d0aea
* WIP: eval target * rename nixos-build to nixos-generate * rename target to format * allow to pass arbitrary format paths * add --help option * add --list option * port the rest of the formats * add short options * be more precise with the file selection * use new trick I learned * support the --run option for the no-gui version: ./nixos-generate --run -f vm-no-gui * document * fixup! port the rest of the formats * fix kexec-bundle
9 lines
153 B
Nix
9 lines
153 B
Nix
{ modulesPath, ... }:
|
|
{
|
|
imports = [
|
|
"${toString modulesPath}/virtualisation/google-compute-image.nix"
|
|
];
|
|
|
|
formatAttr = "googleComputeImage";
|
|
}
|