mirror of
https://github.com/nix-community/nixos-generators.git
synced 2024-11-22 18:24:59 +03:00
55 lines
1.7 KiB
Nix
55 lines
1.7 KiB
Nix
{ config, lib, pkgs, modulesPath, ... }:
|
|
let
|
|
extlinux-conf-builder =
|
|
import "${toString modulesPath}/system/boot/loader/generic-extlinux-compatible/extlinux-conf-builder.nix" {
|
|
pkgs = pkgs.buildPackages;
|
|
};
|
|
|
|
in {
|
|
imports = [
|
|
"${toString modulesPath}/installer/sd-card/sd-image.nix"
|
|
];
|
|
|
|
boot.loader = {
|
|
grub.enable = false;
|
|
generic-extlinux-compatible.enable = true;
|
|
};
|
|
|
|
boot.consoleLogLevel = lib.mkDefault 7;
|
|
|
|
# The serial ports listed here are:
|
|
# - ttyS0: for Tegra (Jetson TX1)
|
|
# - ttyAMA0: for QEMU's -machine virt
|
|
# Also increase the amount of CMA to ensure the virtual console on the RPi3 works.
|
|
boot.kernelParams = ["cma=32M" "console=ttyS0,115200n8" "console=ttyAMA0,115200n8" "console=tty0"];
|
|
|
|
sdImage = {
|
|
populateFirmwareCommands = let
|
|
configTxt = pkgs.writeText "config.txt" ''
|
|
kernel=u-boot-rpi3.bin
|
|
|
|
# Boot in 64-bit mode.
|
|
arm_control=0x200
|
|
|
|
# U-Boot used to need this to work, regardless of whether UART is actually used or not.
|
|
# TODO: check when/if this can be removed.
|
|
enable_uart=1
|
|
|
|
# Prevent the firmware from smashing the framebuffer setup done by the mainline kernel
|
|
# when attempting to show low-voltage or overtemperature warnings.
|
|
avoid_warnings=1
|
|
'';
|
|
in ''
|
|
(cd ${pkgs.raspberrypifw}/share/raspberrypi/boot && cp bootcode.bin fixup*.dat start*.elf $NIX_BUILD_TOP/firmware/)
|
|
cp ${pkgs.ubootRaspberryPi3_64bit}/u-boot.bin firmware/u-boot-rpi3.bin
|
|
cp ${configTxt} firmware/config.txt
|
|
'';
|
|
populateRootCommands = ''
|
|
mkdir -p ./files/boot
|
|
${extlinux-conf-builder} -t 3 -c ${config.system.build.toplevel} -d ./files/boot
|
|
'';
|
|
};
|
|
|
|
formatAttr = "sdImage";
|
|
}
|