plasma-manager/modules/windows.nix
Heitor Augusto 6f1db348fc
Some checks failed
GitHub Pages Docs Generation / publish (ubuntu-latest) (push) Has been cancelled
Add treefmt for formatting and format everything (#370)
2024-09-22 12:57:32 -03:00

29 lines
676 B
Nix

# Window configuration:
{ config, lib, ... }:
let
cfg = config.programs.plasma;
in
{
options.programs.plasma.windows = {
allowWindowsToRememberPositions = lib.mkOption {
type = with lib.types; nullOr bool;
default = null;
description = ''
Allow apps to remember the positions of their own windows, if
they support it.
'';
};
};
config = (
lib.mkIf (cfg.enable && cfg.windows.allowWindowsToRememberPositions != null) {
programs.plasma.configFile = {
kdeglobals = {
General.AllowKDEAppsToRememberWindowPositions = cfg.windows.allowWindowsToRememberPositions;
};
};
}
);
}