srvos/default.nix
zowoq 7a5f6d8ff5 dev flake
This allows us to have private dev inputs that we can use in the main flake and move the github actions checks to buildbot.
2024-01-14 09:08:22 +10:00

15 lines
464 B
Nix

# This file provides backward compatibility to nix < 2.4 clients
{ system ? builtins.currentSystem, src ? ./. }:
let
lock = builtins.fromJSON (builtins.readFile ./dev/private/flake.lock);
inherit (lock.nodes.flake-compat.locked) owner repo rev narHash;
flake-compat = fetchTarball {
url = "https://github.com/${owner}/${repo}/archive/${rev}.tar.gz";
sha256 = narHash;
};
flake = import flake-compat { inherit src system; };
in
flake.defaultNix