weeder/default.nix
Tristan de Cacqueray 9732ba1e28
Support GHC 9.6 (#115)
Co-authored-by: Ollie Charles <ollie@ocharles.org.uk>
2023-06-23 12:12:16 +01:00

37 lines
960 B
Nix

{ compiler-nix-name ? "ghc961" }:
let
haskellNix = import (import ./nix/sources.nix)."haskell.nix" {};
nixpkgsSrc = haskellNix.sources.nixpkgs;
nixpkgsArgs = haskellNix.nixpkgsArgs;
pkgs = import nixpkgsSrc nixpkgsArgs;
in
pkgs.haskell-nix.project {
inherit compiler-nix-name;
src = pkgs.haskell-nix.haskellLib.cleanGit {
name = "weeder";
src = ./.;
};
modules = [{
nonReinstallablePkgs = [
"rts" "ghc-heap" "ghc-prim" "integer-gmp" "integer-simple" "base"
"deepseq" "array" "ghc-boot-th" "pretty" "template-haskell"
# ghcjs custom packages
"ghcjs-prim" "ghcjs-th"
"ghc-bignum" "exceptions" "stm"
"ghc-boot"
"ghc" "Cabal" "Win32" "array" "binary" "bytestring" "containers"
"directory" "filepath" "ghc-boot" "ghc-compact" "ghc-prim"
# "ghci" "haskeline"
"hpc"
"mtl" "parsec" "process" "text" "time" "transformers"
"unix" "xhtml" "terminfo"
];
}];
}