1
1
mirror of https://github.com/qfpl/applied-fp-course.git synced 2024-10-05 16:37:53 +03:00
applied-fp-course/shell.nix
Jack Kelly 97bd67c92f Modernise nix somewhat
* Provide a flake, but support `nix-shell` using flake-compat
* Use `haskellPackages.developPackage` to call `cabal2nix` for us
* Fix a lot of cabal file bounds to bring it into the modern age
* Drop support for GHC <8.4.1 because I can't remember the right way
  to write the conditional `semigroups` dependency
* Drop references to Freenode
* Clarify some documentation
2022-03-15 16:18:30 +10:00

11 lines
293 B
Nix

(import (
let
lock = builtins.fromJSON (builtins.readFile ./flake.lock);
in fetchTarball {
url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
sha256 = lock.nodes.flake-compat.locked.narHash;
}
) {
src = ./.;
}).shellNix