psfp/components/shell.nix
Mark Eibes 4e7334be70 pscide
2020-01-26 09:39:17 +01:00

16 lines
385 B
Nix

{ pkgs ? import <nixpkgs> {} }:
with pkgs;
let
easyPS = import (pkgs.fetchFromGitHub {
owner = "justinwoo";
repo = "easy-purescript-nix";
rev = "ee8d4545c3eb14ea75b789dbfb84e4e8573941b5";
sha256 = "16bcllaf2ra0cbgkc5vlirkh2kkf16237xp4wng6314m3fsxmmag";
}) { inherit pkgs; };
in stdenv.mkDerivation {
name = "env";
buildInputs = with easyPS; [ purs spago ];
}