xrefcheck/default.nix
Savely Krendelhoff 015b12126a
[Chore] Flakify xrefcheck
Problem: For historical reasons some Serokell projects use niv to
organize nix-related dependencies. However, the majority of other
projects in our company use nix flakes to organize these dependencies.

Solution: Add flake and provide ci attibutes as flake outputs.
2023-02-03 13:58:12 +03:00

15 lines
559 B
Nix

# SPDX-FileCopyrightText: 2023 Serokell <https://serokell.io>
# SPDX-License-Identifier: MPL-2.0
let
inherit (import
(let lock = builtins.fromJSON (builtins.readFile ./flake.lock); in
fetchTarball {
url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
sha256 = lock.nodes.flake-compat.locked.narHash;
})
{ src = ./.; }) defaultNix;
system = builtins.currentSystem;
in defaultNix //
(defaultNix.legacyPackages.${system}.lib.attrsets.mapAttrs (_: val: val.${system}) defaultNix)