tix-papers/default.nix
2017-05-12 16:18:33 +02:00

24 lines
466 B
Nix

{
nixpkgs ? <nixpkgs>, system ? builtins.currentSystem
}:
with import nixpkgs { inherit system; };
stdenv.mkDerivation rec {
name = "papers.pdf";
version = "0.0";
buildInputs = [
(texlive.combine {
inherit (texlive) scheme-medium syntax todo;
})
biber
];
src = ./.;
installPhase = ''
mkdir -p $out/nix-support
cp out/main.pdf $out/
echo "file pdf $out/main.pdf" >> $out/nix-support/hydra-build-products
'';
}