1
1
mirror of https://github.com/tweag/asterius.git synced 2024-09-11 08:55:32 +03:00
asterius/shell.nix
Cheng Shao 2e8f8c5bfc WIP
2021-04-23 18:36:23 +00:00

36 lines
631 B
Nix

{ sources ? import ./nix/sources.nix { }
, pkgs ? import sources.nixpkgs {
overlays = [
(import ./nix/binaryenOverlay.nix)
];
}
}:
(pkgs.buildFHSUserEnv {
name = "hs-fhs";
targetPkgs = ps: (with ps; [
haskellPackages.alex
autoconf
automake
binaryen
binutils
gcc
haskell.compiler.ghc884
git
gmp.dev
haskellPackages.happy
ncurses.dev
nodejs-15_x
(python39.withPackages (ps: with ps; [
recommonmark
sphinx
]))
stack
zlib.dev
]);
profile = ''
export LANG=en_US.utf8
unset NIX_SSL_CERT_FILE
unset SSL_CERT_FILE
'';
}).env