git.iko.soy/typeable/cabal2nix
on master help sign in
hackage2nix: don't update to vector 0.11.x yet
60b2ad4Peter Simons
src/hackage2nix.hs+1
@@ -260,6 +260,7 @@ defaultConfiguration = Configuration
260 , defaultPackageOverrides = map (\s -> fromMaybe (error (show s ++ " is not a valid override selector")) (simpleParse s))
260 , defaultPackageOverrides = map (\s -> fromMaybe (error (show s ++ " is not a valid override selector")) (simpleParse s))
261 [ "errors < 2" -- the update breaks some ~40 important packages
261 [ "errors < 2" -- the update breaks some ~40 important packages
262 , "tar < 0.4.2.0" -- later versions fail the regression test suite
262 , "tar < 0.4.2.0" -- later versions fail the regression test suite
263+ , "vector < 0.11" -- breaks lens 4.12
263 ]
264 ]
264
265
265 , corePackages = map (\s -> fromMaybe (error (show s ++ " is not a valid core package")) (simpleParse s))
266 , corePackages = map (\s -> fromMaybe (error (show s ++ " is not a valid core package")) (simpleParse s))