rollbar-hs/default.nix
joneshf 79f82a54ac
Move to a nix-based setup
With nix, we get more reproducable builds.
Everything that goes into making the build can be specified.
The dependencies we need for development/CI can be made the same.

And, we ought to be able to parameterize the build better.
When we want to check if things compile on 8.4.x,
we can change the compiler to that version in one place.

Assuming this works out, it should make for a lower amount of overall work.
2018-08-09 08:09:26 -07:00

22 lines
745 B
Nix

{ mkDerivation, aeson, base, bytestring, case-insensitive, hostname
, hspec, hspec-golden-aeson, http-client, http-conduit, http-types
, network, QuickCheck, stdenv, text, time, unordered-containers
, uuid
}:
mkDerivation {
pname = "rollbar-hs";
version = "0.3.1.0";
src = ./.;
libraryHaskellDepends = [
aeson base bytestring case-insensitive hostname http-client
http-conduit http-types network text time unordered-containers uuid
];
testHaskellDepends = [
aeson base bytestring case-insensitive hspec hspec-golden-aeson
QuickCheck text unordered-containers
];
homepage = "https://github.com/joneshf/rollbar-hs#readme";
description = "Core Rollbar data types and APIs";
license = stdenv.lib.licenses.bsd3;
}