git.iko.soy/typeable/cabal2nix
on master help sign in
hackage2nix.hs: don't upgrade to blaze-builder 0.4.x yet
commit94989f149c65beb3ede3447a6169697ea9da02c6 authorPeter Simons <simons@cryp.to> dateThu 12 Feb 2015, 21:10 (12 years ago) parenta500906
1 file changed+2−1
src/hackage2nix.hs+2−1
src/hackage2nix.hs+2−1
@@ -257,7 +257,8 @@ defaultConfiguration = Configuration
257257 , compilerId = CompilerId GHC (Version [7,8,4] [])
258258
259259 , defaultPackageOverrides = map (\s -> fromMaybe (error (show s ++ " is not a valid override selector")) (simpleParse s))
260− [ "control-monad-free < 0.6" -- newer versions don't compile with anything but GHC 7.8.x
260+ [ "blaze-builder < 0.4" -- the new version breaks many builds, like streaming-commons
261+ , "control-monad-free < 0.6" -- newer versions don't compile with anything but GHC 7.8.x
261262 , "mtl == 2.1.*" -- newer versions require transformers > 0.4.x, which we cannot provide in GHC 7.8.x
262263 , "HStringTemplate < 0.8" -- 0.8 depends on time >= 1.5, which we cannot provide in GHC 7.8.x
263264 , "utf8-string < 1" -- version 1 breaks several packages right now, most notably hint